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Drafting Workbench 

 

 

 



What is Drafting 

 

 
• Generative Drafting workbench 

automatically generates the views of 

geometry from the 3D as well as dimensions 

 

 

• A drawing can be generated at any time. If 

the part or product is changed, the drawing 

will be automatically updated because of the 

associative link. 

 

 

 

 

 

 

 

 
 



How to enter Drafting 

workbench. 
 
 

1. Select Start -> Mechanical Design -> 

Drafting from the menu bar. 
 

 
 

Or 

2. Select File -> New and select Drawing in 

List of Types. 
 

   
 

The New Drawing dialog box appears. Then 

choose Standard and Sheet Style. 
 

 



Drawing interface 
 

The Drawing workbench looks as follows (Fig. 

3) 
 

 
Fig. 3. The Drawing workbench. 

 

 

 

 

 

 

 

 

 



 

Drafting Tool Bars 
There are four standard tool bars found in 

Drafting Workbench. The four tool bars are 

shown below. Some tools have an arrow 

located at the bottom right of the tool icon. To 

display the other tool options you must select 

and hold the left mouse button on the arrow. 

 

1. The Views Tool Bar 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. The Drawing Tool Bar 

 

  

 

 

Front View 

Offset Section View 
 

Detail View 
 

Clipping View 

Broken View 
 

View Creation Wizard 
 

Front, Unfolded, View From 3D, Projection, 

Auxiliary, Isometric View, Advanced Front View 

Offset, Aligned Section View, 

Offset, Aligned Section Cut 
 

Clipping View, Clipping View  

Profile 

Detail View, Detail View 

Profile, Quick Detail View, 

Quick Detail View Profile 

Broken View, Breakout View 

View Creation Wizard, Front 

Top and Left, Front Bottom 

and Right, All Views 

New Sheet, New 

detail Sheet New Sheet  

New View 

Instantiate 2D 

Component 



3. The Annotations Tool Bar 

 

 

 

 

 

 

 

4. The Dimensioning Tool Bar  

 

 

 

 

  

 

 

 

 

 

 

 

Text, Text with Leader, Text 

Replicate, Balloon, Datum 

Target, Text Template 

Placement 

Roughness Symbol, 

Welding Symbol, Weld 

 

Text 

Roughness Symbol 

Table Table, Table from CSV 

Dimensions 

Technological 

Feature Dimensions 

Re-route Dimension 

Datum Feature 

Dimensions, Chained, Cumulated, Stacked, 

Length/Distance, Angle, Radius, Diameter, 

Chamfer, Thread and Coordinate Dimensions, 

Hole Dimension Table, Coordinate Dimension 

Table   

Technological Feature 

Dimensions, Multiple Intra, 

Chained, Length, angle, 

Radius and Demeter 

Technological Feature 

Dimensions Re-route Dimension, 

Create and Remove 

Interruption(s) 

Datum Feature, 

Geometrical Tolerance 



Generative Drafting 
 

Creating Views 

 
Views can be created in various ways: 

• Individually one by one 

• View Wizard 

 

Example No. 1. Individually one by one 

 

Many types of views can be created one by 

one in an approach. 

 

1. Open Draft1 file. 
 

 
 

2. Then open Drafting Workbench and in 

Standard options select ISO standard and in 

Sheet Style choose A0 ISO format. Then select 



The Front Views icon . Then activate the 

CATPart (Draft1) document. 
 

  
 

3. Select your front view plane (select yz 

plane). A preview will be shown on the 

drawing sheet. 
 

  
 

4. Before accepting the view you can reorient 

it with the view manipulator. 

  
Up, down right and left arrows flip 

background plane view about 90 deg.  



Center left and right arrows rotate view 30 

deg about the same plane. The 30 deg 

increment can be changed with the contextual 

menu on the dial. 

5. Click two times on right arrow and click on 

dial center or on sheet to generate the front 

view. 
 

 
 

6. Then add a new view to this drawing. 

Activate the front view and select the 

Projection View icon . Then move the 

drawing where you want it to be projected. 

Select desired location to place the view. 
 

  
 

Generate another view (repeat the procedure). 
 



 
 

 

Example No. 2. The View Wizard 

 

The View Wizard provides with the ability to 

quickly create a variety of standard view 

configurations or build a specific view 

configuration. 

 

1. Select the All Views icon . Then activate 

the CATPart (Draft1) document and select 

“yz plane”. Rotate front view about 180deg on 

left and click on dial center or on sheet to 

generate the views 
 



  
 

 

You can choose different configuration views. 

 

Example No. 3. View Creation Wizard.  

 

1. Select the View Creation Wizard icon . 

The View Wizard: Predefined Configurations 

dialog box appears. 
 

  
 

2. Select one of the view configurations and 

the Next button for additional views. The 

View Wizard: Arranging Configurations 

dialog box appears. Then, select and place any 

additional views (Right view) to the existing 



view configuration and confirm by clicking 

Finish button. Then activate the CATPart 

(Draft1) document and select “yz plane”. 

Rotate front view about 180deg on the left and 

click on dial center or on sheet to generate the 

views. 
 

  
 

Active view is in red frame (for active view 

you can generate additional views). Double-

click on the blue frame to activate it or use 

contextual menu. 

 

Additional View Generation 
 

Example No. 4. Auxiliary View. 

 

1. Activate the front view and select the 

Auxiliary View icon . Then sketch the 

representation of the plane or select an edge 

(1) on the drawing and drag the mouse to see 



the preview of auxiliary view. Then select a 

place on the drawing to create the auxiliary 

view. 
 

   
 

Example No. 5. Isometric View. 

 

1. Select the Isometric View icon . Then, 

activate the CATPart (Draft1) document and 

select a face of the part. A preview of the 

isometric view displays. You can rotate it (use 

the View Manipulator). Then select a place on 

the drawing to create the isometric view. 
 

  

 

1 



 

Sections Views 
There are three main types of sectional views: 

full section, offset or aligned depending on 

how the cutting plane is defined. 

 

Example No. 6. Offset Section View. 

 

a) Simple offset section – a full section with a 

simple single plane fully passing through the 

part. 

1. Select the Offset Section View icon . Then 

sketch cutting line and select a place on the 

drawing to create the offset section view. 
 

   
 

b) Complex offset section – a full section in 

which the cutting plane is offset to pass 

through important features 



2. Select the Offset Section View icon . Then 

sketch cutting line and select a place on the 

drawing to create the offset section view. 
 

   
 

Example No. 7. Aligned Section View. 

 

Aligned section has a cutting plane revolving 

around an axis 

1. Select the Aligned Section View icon . 

Then sketch cutting line and select a place on 

the drawing to create the offset section view. 
 

 
 

Example No. 8. Detail View. 



Detail views can be fully detailed views that 

are calculated from 3D part or quick detailed 

views that are calculated from the defining 

view. 

1. Select Quick Detail View icon . Then 

define the center of the circle by clicking on 

the front view and click to define the circle 

radius, then, move mouse to place the detail 

view. 
 

   
 

Detail can be defined by circular perimeter or 

profile perimeter (Quick Detail View Profile 

). 

 

Example No. 9. Clipping View. 

 

Clipping view can be defined by circular 

perimeter or profile perimeter. Clipping will 



remove all the existing view’s geometry that is 

not in the “callout.” 

1. Select Clipping View icon . Then define 

the center of the circle by clicking on the front 

view and click to define the circle radius. The 

result is displayed. 
 

  
 

Example No. 10. Broken View. 

 

Broken view allows for creation of local cut 

(by a plane) in order to see the inside of part 

without cutting it totally. 

1. Select New Sheet icon  and generate new 

front view. 
 



 
 

2. The select Broken View icon . Then, 

define the break out area by clicking the 

location for the first break limit line (select 

point inside the view) (1), click on the desired 

area to get the vertical break out (2). Then, 

select a point inside the view to indicate the 

position of the second breakout line (3) and 

click on the sheet to generate the broken view 

(4). 
 

  

(1) (2) 



  
 

Modifying Section and Detail 

Profiles  
You can modify section and detail profiles at 

every time. 

 

Example No. 11. Modifying Section View 

Profile. 

1. Double-click on the Section view profile    

B-B (1) to open Edit/Replace toolbar . 

Select the Replace Profile icon  and create 

new callout profile (2) and select the End 

Profile Edition icon  to apply the 

modification (3). 
 

(3) (4) 



   
 

2. Double-click on the Section view profile    

B-B (1) to open Edit/Replace toolbar . 

Select the Invert Profile Direction icon  (2)  

and select the End Profile Edition icon  to 

apply the modification (3). 
 

   
 

3. Then, click on the section view B-B frame 

and move it to the bottom front view. 
 

(1) (2) (3) 

(1) (2) (3) 



 
 

Example No. 12. Modifying Detail View 

Profile. 

 

1. Double-click on the Detail view profile to 

open Edit/Replace toolbar . Select the 

Replace Profile icon and create new callout 

profile (1) (new center point and radius of 

circle) and select the End Profile Edition icon 

to apply the modification (2). 
 

  

 



Sheet properties 
Select the Sheet.1 to modify the properites in 

the tree and Properties with the contextual 

menu. 
 

  
 

The Properties dialog box appears. You can 

change a name, scale or projection method. 

You can change view properties. Select the 

Detail view to modify the properties in the 

tree or detail view frame and Properties with 

the contextual menu. The Properties dialog 

box appears. You can change a name, scale 

(write in 3:1) or orientation. 
 



 
 

Dimension Generation 
 

Generate Dimension (Automatic). 
 

Generate Dimension is a option that generates 

dimensions from existing 3D Part constrains 

(dimension constraints). Dimensions can be 

generated with two methods: 

• In One Step 

• Step by Step 

 

Example No. 13. Generate Dimension (one 

step) 

 



1. Activate the right Section view and select 

Generate Dimension icon . The Dimension 

Generation Filters dialog box appears. In 

Type of Constraints options mark Sketcher 

constraints, 3D constraints and Measured 

constraints and click OK. 
 

 
 

2. The Generated Dimension Analysis dialog 

box appears. In Constraint Analysis 3D 

options mark Generated constraints and in 

Dimension Analysis 2D options mark 

Generation dimensions and click OK. 

 



  
 

3. Then you can use Automatic Positioning 

options to reposition dimensions or reposition 

dimensions manually. 

Select the Section view and select Dimension 

Positioning icon . Dimensions have been 

repositioned automatically. 
 

 
 

Example No. 14. Generate Dimension (step by 

step) 

 



1. Remove dimensions generated previously. 

Then select section view and select Generate 

Dimension Step by Step icon . The 

Dimension Generation Filters dialog box 

appears. In Type of Constraints options mark 

Sketcher constraints, 3D constraints and 

Measured constraints and click OK. 
 

 
 

2. The Step by Step Generation Dimension 

dialog box appears. In Timeout options write 

2 seconds (this is a delay between each 

dimension generated) and select the Next 

Dimension Generation icon. Dimension will be 

generated. Select Pause icon – now you can 

use Transfer option to relocate a dimension to 

another view (select the frame of the view to 

which the dimension is to be transferred) or 

Not Generated option to discard any 

unwanted dimensions. Then continue 



generation process by selecting Next icon 

again. 
 

 
 

Adding Dimensions (manually) 
 

You can create additional dimensions 

manually. Many options to manual 

dimensioning are in Dimensioning toolbar 

(those options are similar to options in 

AutoCAD application) 

 

Example No. 15 

 

1. Activate bottom Section view. Then select 

Diameter Dimension icon  and select a hole 

on the view (1). The dimension type is 

automatically defined according to the 

selected elements (or in the Tools Palette 

). The command options in the 



Tools Palette allows you to position the 

dimension using one of the modes. Then 

choose location dimension on the drawing (2). 
 

  
 

2. Create a linear dimension. Select 

Dimensions icon  and select the vertical line 

(1) and choose location on the drawing (2). 
 

  
 

Modifications part 
If you modify your part in Part Design, you 

can update your sheet. 

 

Example No. 16 

 

(1) (2) 

(1) (2) 



1. Activate the CATPart (Draft1) document 

and change Pad length value (on 150). Then 

activate the CATDrawing document and 

select Update current sheet icon . 
 

  
 

Adding Title Block 
Example No. 17 

 

1. Change format sheet in Sheet Properties 

options on A1 ISO. 
 

  
 

2. Then change the sheet Background with 

Edit → Background menu. 

After Before 



 

  
 

3. Then select Insert → Drawing → Frame 

and Title Block menu. The Insert Frame and 

Title Block dialog box appears. In Style of 

Titleblock options you can chose different 

styles of title block. Confirm by clicking OK 

button.  
 

  
 

 
 



4. Use the geometric tools to draw the title 

block and use text tools to fill in all necessary 

information. When finished, go back to 

Working View from the Edit menu. 

 

Task No. 1 

Create drawing as the following one (open the 

Draft2 file) 

 

 

 

 

 

 

 

 

 
 



 
 

 

The materials used to write the instruction 

come from Dassault Systemes©  


